You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Val (Jun 17th 2011, 10:57pm)

4 275

by Val

(Jun 18th 2011, 7:07pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 446

by hi.todd

(Aug 30th 2009, 9:32pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 210

by jmduke7

(Aug 16th 2006, 6:36pm)

by paterjb (Jan 5th 2004, 7:46am)

5 332

by RVLI

(Jan 6th 2004, 3:16pm)

by tmshead (Oct 1st 2007, 4:35am)

2 382

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by trapkoch (Jul 5th 2009, 10:20am)

1 270

by mrfixit

(Jul 5th 2009, 12:46pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,075

by PhoenixDen

(Jun 24th 2010, 11:27am)

by jbbnet (Aug 19th 2004, 5:11pm)

3 178

by SamIV

(Aug 29th 2004, 5:43am)

by andyl (Apr 21st 2014, 8:32pm)

3 154

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 388

by GatorGuy

(Mar 14th 2012, 7:35am)

Show

Statistics:

438 Threads - 1,664 Posts (average 0.36 Posts per Day)