You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RC (Nov 6th 2011, 7:46pm)

2 230

by Wet_Boots

(Nov 7th 2011, 7:57am)

by grph (Aug 31st 2005, 3:56am)

1 229

by Jazzer K

(Sep 2nd 2005, 6:25pm)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 228

by PerryNZ

(Mar 14th 2014, 12:16am)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 227

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by frankmanic (Aug 5th 2010, 8:44am)

0 227

No reply

by Kim (Jun 19th 2010, 6:45am)

1 227

by mrfixit

(Jun 19th 2010, 12:11pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 227

by mrfixit

(Jul 10th 2009, 2:31pm)

by lloydlevy (Nov 28th 2011, 11:14am)

3 226

by Wet_Boots

(Nov 29th 2011, 8:22am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 226

by aziz786

(Aug 10th 2010, 12:49pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 225

by Scott76

(May 2nd 2013, 2:06pm)

Show

Statistics:

438 Threads - 1,665 Posts (average 0.36 Posts per Day)