You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by richard1975 (Apr 28th 2013, 7:12pm)

1 308

by Scott76

(May 2nd 2013, 2:06pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 307

by AdamT

(Jun 7th 2012, 9:14pm)

by Moggie (Jun 4th 2011, 10:48am)

1 305

by Mitchgo

(Jun 5th 2011, 1:28pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 302

by Wet_Boots

(Nov 27th 2006, 6:04am)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 299

by mrfixit

(Mar 22nd 2014, 1:58am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 299

by jmduke7

(Aug 7th 2007, 11:20am)

by Binks (Apr 10th 2013, 1:28am)

1 298

by mrfixit

(Apr 10th 2013, 3:02am)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 297

by GatorGuy

(Jul 3rd 2012, 8:00am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 297

by alf51175

(Aug 2nd 2011, 8:02pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 297

No reply

Show

Statistics:

472 Threads - 1,758 Posts (average 0.36 Posts per Day)