You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by DRegs (May 5th 2010, 5:29pm)

1 265

by Wet_Boots

(May 6th 2010, 2:34pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 756

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 158

by ahersman

(Sep 30th 2009, 6:15pm)

by mharden5 (Jul 11th 2009, 12:45pm)

1 182

by hi.todd

(Jul 11th 2009, 9:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 212

by mrfixit

(Jul 11th 2009, 11:59am)

by wingnut (Jul 9th 2009, 10:29pm)

1 187

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 232

by mrfixit

(Jul 5th 2009, 12:46pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 362

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 216

by Wet_Boots

(Jun 26th 2009, 8:58am)

by bbruck (Jun 20th 2009, 7:11pm)

1 318

by Wet_Boots

(Jun 21st 2009, 8:31am)

Show

Statistics:

430 Threads - 1,625 Posts (average 0.36 Posts per Day)