You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 494

by mrfixit

(Mar 22nd 2014, 1:58am)

by PATS (Aug 17th 2005, 2:22am)

1 493

by Wet_Boots

(Aug 17th 2005, 2:45am)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 492

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 492

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Wharfrat (May 16th 2008, 11:43am)

1 492

by mrfixit

(May 16th 2008, 5:43pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 491

by AdamT

(Jun 7th 2012, 9:14pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 491

by Mitchgo

(Jun 6th 2011, 9:34pm)

by torodude (Aug 27th 2004, 12:47pm)

1 489

by SprinklerGuy

(Aug 30th 2004, 8:24am)

by Binks (Apr 10th 2013, 1:28am)

1 488

by mrfixit

(Apr 10th 2013, 3:02am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 486

No reply

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)