You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by mosida (Sep 29th 2004, 9:16am)

3 381

by nestors

(Oct 31st 2004, 1:27pm)

by modetz (Jun 16th 2012, 11:23am)

1 380

by Wet_Boots

(Jun 16th 2012, 12:29pm)

by tbatrof (Sep 10th 2011, 7:00pm)

2 378

by mrfixit

(Sep 10th 2011, 10:07pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 375

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 374

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 374

by Rendaug

(Feb 8th 2004, 10:37am)

by tinkermaniac (Aug 21st 2002, 2:36pm)

1 374

by Rays Sprinklers

(May 17th 2003, 2:51pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 373


(Mar 16th 2004, 2:57pm)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 371

No reply

by jbalduf (May 31st 2007, 3:04pm)

1 371

by HooKooDooKu

(Jun 1st 2007, 9:13am)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)