You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by patk (Sep 18th 2011, 2:17pm)

2 702

by patk

(Sep 18th 2011, 3:41pm)

by danny1949 (Sep 22nd 2011, 12:04pm)

1 256

by Wet_Boots

(Sep 22nd 2011, 5:05pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 435

by mulletmac

(Oct 1st 2011, 11:26am)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 196

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by RT (Oct 12th 2011, 8:10pm)

1 639

by mrfixit

(Oct 12th 2011, 11:29pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 344

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 204

by mrfixit

(Oct 16th 2011, 2:26am)

by bdt (Oct 17th 2011, 9:50am)

2 419

by Mitchgo

(Oct 17th 2011, 12:59pm)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 351

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by jeffg (Oct 22nd 2011, 6:06pm)

1 417

by Wet_Boots

(Oct 23rd 2011, 11:52am)

Show

Statistics:

464 Threads - 1,709 Posts (average 0.37 Posts per Day)