You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by PSpatches (Apr 28th 2009, 10:31am)

1 233

by Candance

(May 9th 2009, 9:13pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 233

by bhungue2

(Oct 15th 2003, 8:06am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 232

by mrfixit

(Sep 10th 2011, 10:07pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 231

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 231

by Wet_Boots

(May 11th 2013, 5:08pm)

by Pastor Mel (Sep 24th 2005, 2:44pm)

2 230

by tozar

(Sep 25th 2005, 4:32pm)

by planersedge (Jun 20th 2012, 2:32pm)

3 229

by planersedge

(Jun 25th 2012, 7:27am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 228

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Val (Jun 17th 2011, 10:57pm)

4 226

by Val

(Jun 18th 2011, 7:07pm)

by Sue (Aug 11th 2005, 10:47am)

4 225

by Jazzer K

(Sep 2nd 2005, 6:27pm)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)