You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by clm716 (Aug 7th 2011, 9:58am)

1 272

by Central Irrigation

(Aug 7th 2011, 10:49am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 302

by alf51175

(Aug 2nd 2011, 8:02pm)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 370

by Smithwilde

(Aug 1st 2011, 8:37pm)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 592

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by JimB (Jul 30th 2011, 3:59pm)

1 227

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 402

by Mitchgo

(Jul 25th 2011, 11:12pm)

by mijd (Jul 20th 2011, 2:56pm)

2 452

by Mitchgo

(Jul 23rd 2011, 3:45am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 756

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by irar (Jul 11th 2011, 5:27pm)

4 534

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 535

by Mitchgo

(Jul 19th 2011, 12:34am)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)