You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Sebastian2015 (Jul 28th 2015, 9:27am)

1 137

by Wet_Boots

(Jul 28th 2015, 11:15am)

by bjlarson (Jul 28th 2015, 9:20am)

1 57

by Wet_Boots

(Jul 28th 2015, 10:04am)

by jackh (Jun 12th 2011, 11:57am)

11 4,350

by mrfixit

(Jul 26th 2015, 2:23pm)

by OldBob (Jul 23rd 2015, 7:37am)

1 98

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 107

by mrfixit

(Jul 17th 2015, 6:45pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 93

by LX2

(Jul 17th 2015, 8:27am)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 115

by Wet_Boots

(Jul 14th 2015, 6:12pm)

by MAG128 (Jun 24th 2015, 5:32pm)

3 230

by Wet_Boots

(Jun 26th 2015, 6:20am)

by Gilgaretch (Jun 23rd 2015, 8:23pm)

0 107

No reply

by Roco8823 (Jun 22nd 2015, 11:43pm)

3 112

by mrfixit

(Jun 23rd 2015, 11:44am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)