You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Don_Mousseau (May 15th 2010, 8:44am)

1 647

by mrfixit

(May 15th 2010, 1:03pm)

by DRegs (May 5th 2010, 5:29pm)

1 333

by Wet_Boots

(May 6th 2010, 2:34pm)

by stephen (May 2nd 2010, 12:11pm)

0 149

No reply

by mahplane (Apr 26th 2010, 5:49pm)

0 298

No reply

by BVISailor (Oct 31st 2009, 10:11am)

1 830

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 217

by ahersman

(Sep 30th 2009, 6:15pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 471

by hi.todd

(Aug 30th 2009, 9:32pm)

by fairplay (Jan 29th 2007, 1:01pm)

9 3,444

by Wet_Boots

(Aug 17th 2009, 7:50pm)

by stillc (Jul 29th 2009, 12:36pm)

2 742

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Panic1978 (Jul 17th 2009, 6:52pm)

0 523

No reply

Show

Statistics:

466 Threads - 1,711 Posts (average 0.37 Posts per Day)