You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by mijd (Jul 20th 2011, 2:56pm)

2 611

by Mitchgo

(Jul 23rd 2011, 3:45am)

by jeffg (Oct 22nd 2011, 6:06pm)

1 610

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by Cherrybark (May 20th 2012, 6:22pm)

2 609

by GatorGuy

(May 21st 2012, 9:04am)

by ohiorebel (Apr 10th 2011, 8:59am)

2 609

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 609

by Wet_Boots

(May 2nd 2005, 2:02am)

by rrsteve (Aug 22nd 2002, 9:53pm)

1 606

by Rays Sprinklers

(May 22nd 2003, 4:13am)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 601

by Smithwilde

(Aug 1st 2011, 8:37pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 599

by Wet_Boots

(Jun 16th 2011, 6:25am)

by waboehly (May 1st 2007, 6:51am)

1 599

by Tom

(May 1st 2007, 3:34pm)

by hettiep (May 27th 2005, 5:02am)

2 598

by Jazzer K

(Sep 2nd 2005, 6:22pm)



518 Threads - 1,976 Posts (average 0.37 Posts per Day)