You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Texas_Pete (May 1st 2005, 7:21pm)

1 594

by Wet_Boots

(May 2nd 2005, 2:02am)

by Cherrybark (May 20th 2012, 6:22pm)

2 593

by GatorGuy

(May 21st 2012, 9:04am)

by ohiorebel (Apr 10th 2011, 8:59am)

2 593

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by hettiep (May 27th 2005, 5:02am)

2 586

by Jazzer K

(Sep 2nd 2005, 6:22pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 584

by Wet_Boots

(Jun 16th 2011, 6:25am)

by jimmyburg (Nov 19th 2007, 6:27am)

1 582

by hi.todd

(Apr 6th 2008, 5:05pm)

by odiaz1 (May 10th 2012, 10:18am)

1 581

by Wet_Boots

(May 10th 2012, 10:26am)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 573

by Mitchgo

(May 9th 2011, 1:04am)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 573

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by planersedge (Jun 20th 2012, 2:32pm)

3 572

by planersedge

(Jun 25th 2012, 7:27am)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)