You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by jimmyburg (Nov 19th 2007, 6:27am)

1 489

by hi.todd

(Apr 6th 2008, 5:05pm)

by Moggie (Jun 4th 2011, 10:48am)

1 358

by Mitchgo

(Jun 5th 2011, 1:28pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 318

by Wet_Boots

(Jun 19th 2006, 6:17am)

by boba (Jul 25th 2005, 7:26am)

0 210

No reply

by runningfreak (May 25th 2011, 7:32pm)

1 326

by Wet_Boots

(May 25th 2011, 8:29pm)

by desmo907 (Aug 28th 2012, 3:54pm)

3 605

by desmo907

(Sep 4th 2012, 8:33am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 299

by evergreenz

(Sep 3rd 2011, 12:08pm)

by martinjames10 (Nov 10th 2004, 8:57am)

5 487

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 694

by s123mith

(Jul 10th 2012, 5:21am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 417

by Wet_Boots

(Jun 26th 2009, 8:58am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)