You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rainman?? (Aug 12th 2016, 12:17pm)

0 657

No reply

by ChucksLandscaping (Apr 20th 2016, 11:19am)

0 311

No reply

by Rey@@%% (Mar 26th 2016, 12:04pm)

0 419

No reply

by Dagobah (Mar 19th 2016, 5:23pm)

0 307

No reply

by JimsLawn (Sep 8th 2015, 2:33pm)

0 590

No reply

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 381

No reply

by Gilgaretch (Jun 23rd 2015, 8:23pm)

0 306

No reply

by artimus (May 13th 2015, 6:06pm)

0 236

No reply

by GardeningHelp87 (May 10th 2015, 3:50pm)

0 263

No reply

by pkilbride (May 3rd 2015, 8:44pm)

0 255

No reply

by DJM8507 (Apr 28th 2015, 12:21pm)

0 429

No reply

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 902

No reply

by tico (Jun 15th 2013, 8:58pm)

0 1,277

No reply

by diegogarcia67 (Sep 22nd 2012, 6:32pm)

0 969

No reply

by rose (Sep 11th 2012, 12:24pm)

0 640

No reply

by sirlar (Jul 20th 2012, 2:40pm)

0 619

No reply

by GatorGuy (May 24th 2012, 10:26am)

0 531

No reply

by raisbarth (Feb 26th 2012, 9:14am)

0 974

No reply

by lkc91311 (Jun 26th 2011, 11:25pm)

0 631

No reply

by Wet_Boots (May 8th 2011, 7:43am)

0 748

No reply

Show

Statistics:

594 Threads - 2,229 Posts (average 0.36 Posts per Day)