You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AZHomeOwner (May 7th 2011, 1:35pm)

1 406

by Mitchgo

(May 9th 2011, 1:04am)

by Wet_Boots (May 8th 2011, 7:43am)

0 299

No reply

by krantzr (Apr 30th 2011, 8:26am)

3 1,260

by mrfixit

(May 1st 2011, 11:34am)

by miker (Apr 30th 2011, 12:53pm)

1 444

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 695

by Wet_Boots

(Apr 26th 2011, 9:20am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 338

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 220

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 723

by Mitchgo

(Apr 10th 2011, 2:29am)

by denm31 (Apr 4th 2011, 3:11pm)

6 611

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by joe decoste (Mar 19th 2011, 11:56am)

1 238

by Wet_Boots

(Mar 20th 2011, 7:29am)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)