You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 13dwf (Sep 7th 2010, 1:03pm)

4 464

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 389

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by sci4kids (Sep 4th 2010, 9:48am)

2 549

by hi.todd

(Sep 4th 2010, 11:45am)

by billt (Aug 28th 2010, 10:20am)

1 213

by Wet_Boots

(Aug 28th 2010, 11:21am)

by kenken55 (Aug 5th 2010, 10:55am)

2 497

by kenken1955

(Aug 28th 2010, 5:32am)

by guy_sparky (Aug 12th 2010, 10:35am)

3 666

by mrfixit

(Aug 12th 2010, 5:12pm)

by aziz786 (Aug 9th 2010, 12:02pm)

2 226

by aziz786

(Aug 10th 2010, 12:49pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 779

by hi.todd

(Aug 10th 2010, 11:57am)

by Fisher (Aug 7th 2010, 5:43pm)

0 158

No reply

by frankmanic (Aug 5th 2010, 8:44am)

0 225

No reply

Show

Statistics:

438 Threads - 1,664 Posts (average 0.36 Posts per Day)