You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fwoodall (Aug 28th 2005, 6:01pm)

2 862

by squints

(Jul 31st 2011, 2:16pm)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 369

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 407

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 219

by Smithwilde

(Aug 1st 2011, 8:37pm)

by alf51175 (Aug 1st 2011, 9:53pm)

3 170

by alf51175

(Aug 2nd 2011, 8:02pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 146

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by clm716 (Aug 7th 2011, 9:58am)

1 171

by Central Irrigation

(Aug 7th 2011, 10:49am)

by Drski (Jul 29th 2011, 11:50am)

5 544

by Drski

(Aug 9th 2011, 11:04am)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 635

by Wet_Boots

(Aug 10th 2011, 7:51am)

by John199 (Aug 14th 2011, 3:57pm)

4 646

by hi.todd

(Aug 15th 2011, 7:29pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)