You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Grahpack (Jun 9th 2011, 7:07pm)

1 742

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 1,067

by Mitchgo

(Jun 9th 2011, 10:08pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 4,779

by Mitchgo

(Jun 12th 2011, 2:13pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 599

by Wet_Boots

(Jun 16th 2011, 6:25am)

by Val (Jun 17th 2011, 10:57pm)

4 703

by Val

(Jun 18th 2011, 7:07pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 402

No reply

by ncampbel (Jul 1st 2011, 2:15pm)

1 1,023

by Mitchgo

(Jul 1st 2011, 9:20pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 672

by Mitchgo

(Jul 11th 2011, 12:24am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 2,347

by Wet_Boots

(Jul 13th 2011, 11:30am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 556

by Wet_Boots

(Jul 15th 2011, 11:06pm)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)