You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nowaterflow (Mar 8th 2013, 3:52pm)

3 363

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 361

by Mitchgo

(Jul 25th 2011, 11:12pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 360

by jmduke7

(Aug 16th 2006, 6:30pm)

by Stu1986 (May 5th 2012, 11:44pm)

3 357

by mrfixit

(May 6th 2012, 1:23pm)

by kazemi (Sep 5th 2005, 11:57am)

3 357

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 356

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 354

by Ianjanson

(Apr 10th 2013, 7:37pm)

by martinjames10 (Nov 10th 2004, 8:57am)

5 353

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 348

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 347

by xpedient

(Jul 2nd 2006, 3:34pm)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.36 Posts per Day)