You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Cherrybark (May 20th 2012, 6:22pm)

2 379

by GatorGuy

(May 21st 2012, 9:04am)

by Stu1986 (May 5th 2012, 11:44pm)

3 378

by mrfixit

(May 6th 2012, 1:23pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 377

by Mitchgo

(Jul 25th 2011, 11:12pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 376

by xpedient

(Jul 2nd 2006, 3:34pm)

by kazemi (Sep 5th 2005, 11:57am)

3 375

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 374

by Ianjanson

(Apr 10th 2013, 7:37pm)

by martinjames10 (Nov 10th 2004, 8:57am)

5 373

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 368

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 361

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by m collins (Jul 5th 2012, 11:04am)

3 359

by GatorGuy

(Jul 5th 2012, 12:27pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)