You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kazemi (Sep 5th 2005, 11:57am)

3 289

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 287

by mrfixit

(Jun 25th 2013, 8:32pm)

by paterjb (Jan 5th 2004, 7:46am)

5 287

by RVLI

(Jan 6th 2004, 3:16pm)

by handan (Nov 30th 2011, 11:30pm)

2 283

by handan

(Dec 2nd 2011, 4:56am)

by avu3 (Jul 3rd 2005, 2:36pm)

4 281

by avu3

(Jul 4th 2005, 7:20pm)

by DRegs (May 5th 2010, 5:29pm)

1 280

by Wet_Boots

(May 6th 2010, 2:34pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 279

by xpedient

(Jul 2nd 2006, 3:34pm)

by Stu1986 (May 5th 2012, 11:44pm)

3 275

by mrfixit

(May 6th 2012, 1:23pm)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 275

No reply

by jchsmiller (Apr 18th 2011, 11:47am)

1 274

by Wet_Boots

(Apr 20th 2011, 12:27pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)