You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RodQ (Jul 11th 2010, 12:54pm)

2 228

by hi.todd

(Jul 12th 2010, 12:49pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 540

by Wet_Boots

(Jun 9th 2011, 10:09am)

by Marvel (Jan 19th 2013, 6:54am)

7 1,056

by Marvel

(Jan 22nd 2013, 7:49pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 232

by Wet_Boots

(Jul 17th 2010, 9:11am)

by MJ (Jul 8th 2007, 5:23am)

0 112

No reply

by jimmyburg (Nov 19th 2007, 6:27am)

1 371

by hi.todd

(Apr 6th 2008, 5:05pm)

by Moggie (Jun 4th 2011, 10:48am)

1 267

by Mitchgo

(Jun 5th 2011, 1:28pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 227

by Wet_Boots

(Jun 19th 2006, 6:17am)

by boba (Jul 25th 2005, 7:26am)

0 140

No reply

by runningfreak (May 25th 2011, 7:32pm)

1 229

by Wet_Boots

(May 25th 2011, 8:29pm)

Show

Statistics:

456 Threads - 1,701 Posts (average 0.37 Posts per Day)