You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by orgits (Apr 9th 2011, 5:10pm)

2 1,305

by Mitchgo

(Apr 10th 2011, 2:29am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 397

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by sci4kids (Sep 4th 2010, 9:48am)

2 775

by hi.todd

(Sep 4th 2010, 11:45am)

by kenken55 (Aug 5th 2010, 10:55am)

2 891

by kenken1955

(Aug 28th 2010, 5:32am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 429

by aziz786

(Aug 10th 2010, 12:49pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 1,075

by hi.todd

(Aug 10th 2010, 11:57am)

by slugbugblue (Jul 16th 2010, 6:40am)

2 403

by Wet_Boots

(Jul 17th 2010, 9:11am)

by RodQ (Jul 11th 2010, 12:54pm)

2 396

by hi.todd

(Jul 12th 2010, 12:49pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,375

by PhoenixDen

(Jun 24th 2010, 11:27am)

by stillc (Jul 29th 2009, 12:36pm)

2 984

by Wet_Boots

(Aug 4th 2009, 1:08am)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)