You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Merv (May 1st 2010, 3:44pm)

3 321

by mrfixit

(May 31st 2010, 9:47pm)

by KSknight (Aug 17th 2009, 10:53am)

1 646

by bdbengtsson

(May 21st 2010, 5:27pm)

by Eclectic (May 17th 2010, 2:01pm)

0 144

No reply

by Don_Mousseau (May 15th 2010, 8:44am)

1 575

by mrfixit

(May 15th 2010, 1:03pm)

by DRegs (May 5th 2010, 5:29pm)

1 276

by Wet_Boots

(May 6th 2010, 2:34pm)

by stephen (May 2nd 2010, 12:11pm)

0 111

No reply

by mahplane (Apr 26th 2010, 5:49pm)

0 267

No reply

by BVISailor (Oct 31st 2009, 10:11am)

1 773

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 170

by ahersman

(Sep 30th 2009, 6:15pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 391

by hi.todd

(Aug 30th 2009, 9:32pm)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)