You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 644

by Wet_Boots

(Dec 26th 2012, 8:32am)

by martinjames10 (Nov 10th 2004, 8:57am)

5 644

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by 206007075 (Sep 28th 2004, 10:26am)

0 643

No reply

by mulletmac (Sep 30th 2011, 7:29am)

2 641

by mulletmac

(Oct 1st 2011, 11:26am)

by water (Oct 23rd 2008, 8:47am)

1 641

by mrfixit

(Oct 23rd 2008, 10:24am)

by dse (Jun 8th 2012, 5:58am)

2 640

by Wet_Boots

(Jun 8th 2012, 8:48am)

by ros (Mar 15th 2012, 7:40pm)

1 636

by hi.todd

(Mar 20th 2012, 9:07pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 635

by Mitchgo

(Jul 11th 2011, 12:24am)

by billt (Aug 28th 2010, 10:20am)

1 632

by Wet_Boots

(Aug 28th 2010, 11:21am)

by ssherrid (Jul 21st 2010, 12:18am)

0 632

No reply

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)