You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jimmyburg (Nov 19th 2007, 6:27am)

1 359

by hi.todd

(Apr 6th 2008, 5:05pm)

by waboehly (May 1st 2007, 6:51am)

1 359

by Tom

(May 1st 2007, 3:34pm)

by jackevln (Aug 20th 2006, 6:33am)

4 359

by mrfixit

(Aug 21st 2006, 5:12pm)

by avu3 (Jul 3rd 2005, 2:36pm)

4 359

by avu3

(Jul 4th 2005, 7:20pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 358

by hi.todd

(Jun 19th 2009, 10:24pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 354

by Wet_Boots

(Sep 16th 2007, 7:55am)

by Cherrybark (May 20th 2012, 6:22pm)

2 352

by GatorGuy

(May 21st 2012, 9:04am)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 351

by mrfixit

(Aug 14th 2013, 12:28pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 351

by Wet_Boots

(May 2nd 2005, 2:02am)

by blh (Jun 4th 2011, 12:55pm)

1 350

by Mitchgo

(Jun 4th 2011, 3:32pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)