You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by gobris (May 14th 2013, 9:45am)

3 385

by Wet_Boots

(May 16th 2013, 8:30am)

by kevin burklund (May 10th 2006, 1:05pm)

0 94

No reply

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 648

by Wet_Boots

(Aug 10th 2011, 7:51am)

by pete57 (Jun 19th 2007, 6:43pm)

0 261

No reply

by jackh (Jun 12th 2011, 11:57am)

9 2,585

by Wet_Boots

(Jun 13th 2011, 9:17am)

by RodQ (Jul 11th 2010, 12:54pm)

2 186

by hi.todd

(Jul 12th 2010, 12:49pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 486

by Wet_Boots

(Jun 9th 2011, 10:09am)

by Marvel (Jan 19th 2013, 6:54am)

7 902

by Marvel

(Jan 22nd 2013, 7:49pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 188

by Wet_Boots

(Jul 17th 2010, 9:11am)

by MJ (Jul 8th 2007, 5:23am)

0 93

No reply

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)