You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kingtpt (Jul 17th 2010, 5:57pm)

5 165

by Fireguy97

(Jul 18th 2010, 11:35pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 165

by Wet_Boots

(Jul 17th 2010, 9:11am)

by RodQ (Jul 11th 2010, 12:54pm)

2 164

by hi.todd

(Jul 12th 2010, 12:49pm)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 995

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by paul b (Jul 3rd 2010, 10:24am)

1 441

by Wet_Boots

(Jul 6th 2010, 9:21am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 137

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by svsprinklers (May 19th 2010, 9:29pm)

2 994

by PhoenixDen

(Jun 24th 2010, 11:27am)

by Greenweenie (Jun 21st 2010, 9:15am)

2 2,638

by Greenweenie

(Jun 22nd 2010, 8:30am)

by Kim (Jun 19th 2010, 6:45am)

1 183

by mrfixit

(Jun 19th 2010, 12:11pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 172

by HooKooDooKu

(Jun 9th 2010, 11:12am)

Show

Statistics:

427 Threads - 1,618 Posts (average 0.36 Posts per Day)