You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by veidtmeister (Jul 29th 2011, 2:02pm)

9 281

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by macminn (May 18th 2007, 5:05pm)

9 280

by SprinklerGuy

(May 25th 2007, 3:19am)

by blh (Jun 4th 2011, 12:55pm)

1 279

by Mitchgo

(Jun 4th 2011, 3:32pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 278

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 278

by hi.todd

(Apr 6th 2008, 5:05pm)

by dse (Jun 8th 2012, 5:58am)

2 277

by Wet_Boots

(Jun 8th 2012, 8:48am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 277

by hi.todd

(Feb 27th 2011, 4:12pm)

by waboehly (May 1st 2007, 6:51am)

1 277

by Tom

(May 1st 2007, 3:34pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 275

by Wet_Boots

(Sep 16th 2007, 7:55am)

by Chuck (Jun 29th 2003, 2:59pm)

3 274

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)