You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by PAP (Aug 19th 2015, 10:04am)

2 675

by PAP

(Sep 8th 2015, 9:57am)

by joe13 (Aug 19th 2012, 12:36pm)

1 672

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by JohnEmery (Jul 31st 2011, 3:48pm)

1 665

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by lschwart (May 2nd 2006, 3:53am)

3 663

by kevin burklund

(May 10th 2006, 12:18pm)

by EtzGx (Jun 21st 2009, 12:40pm)

0 662

No reply

by nowaterflow (Mar 8th 2013, 3:52pm)

3 661

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by jack z (Apr 8th 2012, 10:35am)

1 661

by mrfixit

(Apr 8th 2012, 2:37pm)

by paul b (Jul 3rd 2010, 10:24am)

1 659

by Wet_Boots

(Jul 6th 2010, 9:21am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 658

by PerryNZ

(Mar 14th 2014, 12:16am)

by dwinmac (Sep 4th 2010, 2:42pm)

3 657

by Wet_Boots

(Sep 5th 2010, 2:55pm)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)