You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by miker (Apr 30th 2011, 12:53pm)

1 444

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by tico (Jun 15th 2013, 8:58pm)

0 442

No reply

by jeffg (Oct 22nd 2011, 6:06pm)

1 441

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 440

by hi.todd

(Feb 27th 2011, 4:12pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 440

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by avu3 (Jul 3rd 2005, 2:36pm)

4 436

by avu3

(Jul 4th 2005, 7:20pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 433

No reply

by Ryanm519 (Jun 16th 2011, 1:28am)

1 432

by Wet_Boots

(Jun 16th 2011, 6:25am)

by tmshead (Oct 1st 2007, 4:35am)

2 431

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by joe13 (Aug 19th 2012, 12:36pm)

1 430

by Wet_Boots

(Aug 19th 2012, 2:35pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)