You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bdt (Oct 17th 2011, 9:50am)

2 413

by Mitchgo

(Oct 17th 2011, 12:59pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 408

by Wet_Boots

(Jun 16th 2011, 6:25am)

by miker (Apr 30th 2011, 12:53pm)

1 408

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 405

by mrfixit

(Jul 2nd 2013, 3:07am)

by dse (Jun 8th 2012, 5:58am)

2 403

by Wet_Boots

(Jun 8th 2012, 8:48am)

by tmshead (Oct 1st 2007, 4:35am)

2 400

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by odiaz1 (May 10th 2012, 10:18am)

1 397

by Wet_Boots

(May 10th 2012, 10:26am)

by mijd (Jul 20th 2011, 2:56pm)

2 397

by Mitchgo

(Jul 23rd 2011, 3:45am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 396

by hi.todd

(Feb 27th 2011, 4:12pm)

by tico (Jun 15th 2013, 8:58pm)

0 393

No reply

Show

Statistics:

455 Threads - 1,700 Posts (average 0.36 Posts per Day)