You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kingtpt (Jul 17th 2010, 5:57pm)

5 179

by Fireguy97

(Jul 18th 2010, 11:35pm)

by Texas Tarheel (Jun 19th 2014, 8:33pm)

8 71

by irrigirl

(Jun 24th 2014, 12:26pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 162

by ahersman

(Sep 30th 2009, 6:15pm)

by DAVID LP (Jul 18th 2011, 10:55am)

2 347

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 228

by mrfixit

(Jun 4th 2010, 7:49pm)

by rickesco (Jul 28th 2004, 8:13am)

3 152

by aquamatic

(Jul 29th 2004, 10:36am)

by Bob H (May 13th 2003, 12:54am)

17 588

by Bob H

(Jun 3rd 2003, 9:20am)

by keitht (Apr 11th 2006, 3:53pm)

1 175

by BSME

(Apr 12th 2006, 5:45am)

by dgaines (Nov 5th 2012, 5:27pm)

3 696

by dgaines

(Nov 10th 2012, 4:15pm)

by Marlene (Aug 23rd 2007, 3:11am)

4 372

by Marlene

(Aug 25th 2007, 5:42am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)