You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by orgits (Apr 9th 2011, 5:10pm)

2 565

by Mitchgo

(Apr 10th 2011, 2:29am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 177

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by sci4kids (Sep 4th 2010, 9:48am)

2 511

by hi.todd

(Sep 4th 2010, 11:45am)

by kenken55 (Aug 5th 2010, 10:55am)

2 461

by kenken1955

(Aug 28th 2010, 5:32am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 195

by aziz786

(Aug 10th 2010, 12:49pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 729

by hi.todd

(Aug 10th 2010, 11:57am)

by slugbugblue (Jul 16th 2010, 6:40am)

2 185

by Wet_Boots

(Jul 17th 2010, 9:11am)

by RodQ (Jul 11th 2010, 12:54pm)

2 182

by hi.todd

(Jul 12th 2010, 12:49pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,028

by PhoenixDen

(Jun 24th 2010, 11:27am)

by Greenweenie (Jun 21st 2010, 9:15am)

2 2,770

by Greenweenie

(Jun 22nd 2010, 8:30am)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)