You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Metalman1 (May 23rd 2011, 11:56am)

3 459

by sharon

(May 30th 2011, 12:20pm)

by runningfreak (May 25th 2011, 7:32pm)

1 229

by Wet_Boots

(May 25th 2011, 8:29pm)

by criceX (May 20th 2011, 9:34pm)

2 459

by criceX

(May 21st 2011, 7:03pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 376

by Mitchgo

(May 9th 2011, 1:04am)

by Wet_Boots (May 8th 2011, 7:43am)

0 282

No reply

by JA (May 9th 2010, 11:27am)

7 4,877

by Wet_Boots

(May 3rd 2011, 6:55am)

by krantzr (Apr 30th 2011, 8:26am)

3 1,202

by mrfixit

(May 1st 2011, 11:34am)

by miker (Apr 30th 2011, 12:53pm)

1 409

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 649

by Wet_Boots

(Apr 26th 2011, 9:20am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 418

No reply

Show

Statistics:

457 Threads - 1,702 Posts (average 0.37 Posts per Day)