You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by schlaiss (Jul 1st 2010, 9:25pm)

1 373

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by paul b (Jul 3rd 2010, 10:24am)

1 684

by Wet_Boots

(Jul 6th 2010, 9:21am)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 1,813

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 444

by hi.todd

(Jul 12th 2010, 12:49pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 466

by Wet_Boots

(Jul 17th 2010, 9:11am)

by kingtpt (Jul 17th 2010, 5:57pm)

5 647

by Fireguy97

(Jul 18th 2010, 11:35pm)

by ssherrid (Jul 21st 2010, 12:18am)

0 646

No reply

by AJ Goldsmith (Jul 21st 2010, 2:48pm)

1 2,813

by Wet_Boots

(Jul 21st 2010, 7:36pm)

by Frankpc (Jul 22nd 2010, 9:02pm)

0 1,446

No reply

by Emblazed (Jul 24th 2010, 10:30am)

5 914

by Wet_Boots

(Jul 27th 2010, 10:48am)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)