You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by water (Oct 23rd 2008, 8:47am)

1 465

by mrfixit

(Oct 23rd 2008, 10:24am)

by Max (May 6th 2007, 8:27pm)

2 465

by Tom

(May 9th 2007, 3:29am)

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 464

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by dunn (Jun 29th 2005, 3:35am)

4 464

by Wet_Boots

(Jul 4th 2005, 6:22am)

by Chuck (Jun 29th 2003, 2:59pm)

3 463

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 461

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by ros (Mar 15th 2012, 7:40pm)

1 456

by hi.todd

(Mar 20th 2012, 9:07pm)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 455

by Wet_Boots

(Dec 26th 2012, 8:32am)

by cassian (Jul 31st 2005, 2:39pm)

4 455

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by dgergits (Aug 29th 2010, 10:02am)

0 452

No reply

Show

Statistics:

436 Threads - 1,669 Posts (average 0.36 Posts per Day)