You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 308

by Mitchgo

(Jul 19th 2011, 12:34am)

by miker (Apr 30th 2011, 12:53pm)

1 307

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by sgb (Jun 5th 2006, 5:30pm)

0 307

No reply

by DAVID LP (Jul 18th 2011, 10:55am)

2 306

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by cassian (Jul 31st 2005, 2:39pm)

4 306

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 305

by chrisratz

(Jun 29th 2012, 11:18pm)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 304

by mrfixit

(Jul 14th 2012, 12:39am)

by sdguy (Mar 10th 2013, 3:15pm)

3 296

by Wet_Boots

(Jul 31st 2013, 10:41am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 296

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by dunn (Jun 29th 2005, 3:35am)

4 296

by Wet_Boots

(Jul 4th 2005, 6:22am)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)