You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by opsec (Apr 1st 2012, 7:44pm)

2 422

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by handan (Nov 30th 2011, 11:30pm)

2 272

by handan

(Dec 2nd 2011, 4:56am)

by RC (Nov 6th 2011, 7:46pm)

2 188

by Wet_Boots

(Nov 7th 2011, 7:57am)

by bdt (Oct 17th 2011, 9:50am)

2 342

by Mitchgo

(Oct 17th 2011, 12:59pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 140

by mrfixit

(Oct 16th 2011, 2:26am)

by mulletmac (Sep 30th 2011, 7:29am)

2 363

by mulletmac

(Oct 1st 2011, 11:26am)

by patk (Sep 18th 2011, 2:17pm)

2 599

by patk

(Sep 18th 2011, 3:41pm)

by tbatrof (Sep 10th 2011, 7:00pm)

2 232

by mrfixit

(Sep 10th 2011, 10:07pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 147

by evergreenz

(Sep 3rd 2011, 12:08pm)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 123

by Wet_Boots

(Aug 23rd 2011, 11:43am)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)