You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by stktrader (May 20th 2012, 5:55pm)

4 369

by Wet_Boots

(May 21st 2012, 7:02am)

by odiaz1 (May 10th 2012, 10:18am)

1 394

by Wet_Boots

(May 10th 2012, 10:26am)

by Stu1986 (May 5th 2012, 11:44pm)

3 319

by mrfixit

(May 6th 2012, 1:23pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 189

by GatorGuy

(Apr 23rd 2012, 8:47am)

by mack (Apr 18th 2012, 8:30pm)

2 510

by mack

(Apr 19th 2012, 12:54pm)

by jack z (Apr 8th 2012, 10:35am)

1 448

by mrfixit

(Apr 8th 2012, 2:37pm)

by opsec (Apr 1st 2012, 7:44pm)

2 489

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by ros (Mar 15th 2012, 7:40pm)

1 438

by hi.todd

(Mar 20th 2012, 9:07pm)

by aa1872 (Mar 17th 2012, 8:22am)

3 275

by GatorGuy

(Mar 19th 2012, 8:41am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 396

by GatorGuy

(Mar 14th 2012, 7:35am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)