You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by blh (Jun 4th 2011, 12:55pm)

1 356

by Mitchgo

(Jun 4th 2011, 3:32pm)

by rbuchas (May 27th 2011, 2:22pm)

8 1,670

by hi.todd

(Jun 3rd 2011, 4:52pm)

by kxaz145 (May 1st 2009, 2:52pm)

3 1,306

by Wet_Boots

(Jun 3rd 2011, 7:49am)

by Metalman1 (May 23rd 2011, 11:56am)

3 452

by sharon

(May 30th 2011, 12:20pm)

by runningfreak (May 25th 2011, 7:32pm)

1 226

by Wet_Boots

(May 25th 2011, 8:29pm)

by criceX (May 20th 2011, 9:34pm)

2 454

by criceX

(May 21st 2011, 7:03pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 373

by Mitchgo

(May 9th 2011, 1:04am)

by Wet_Boots (May 8th 2011, 7:43am)

0 276

No reply

by JA (May 9th 2010, 11:27am)

7 4,842

by Wet_Boots

(May 3rd 2011, 6:55am)

by krantzr (Apr 30th 2011, 8:26am)

3 1,188

by mrfixit

(May 1st 2011, 11:34am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)