You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jwdawgs (Feb 26th 2007, 4:10pm)

11 463

by Tom

(Feb 28th 2007, 12:48pm)

by chpsk8 (Mar 17th 2002, 5:25am)

1 229

by RVLI

(Mar 20th 2002, 12:31pm)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 188

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by mikem (Jan 4th 2004, 7:33pm)

0 175

No reply

by Pastor Mel (Sep 24th 2005, 2:44pm)

2 255

by tozar

(Sep 25th 2005, 4:32pm)

by mosida (Sep 29th 2004, 9:16am)

3 233

by nestors

(Oct 31st 2004, 1:27pm)

by tabong (Jun 18th 2006, 5:10pm)

1 162

by Wet_Boots

(Jun 19th 2006, 5:44am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 663

by Mitchgo

(Jul 1st 2011, 9:20pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 612

by zenavttmn

(Apr 24th 2006, 1:21pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 167

by Wet_Boots

(Jun 12th 2005, 1:13pm)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)