You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by chrisratz (Jun 27th 2012, 7:40pm)

4 510

by chrisratz

(Jun 29th 2012, 11:18pm)

by macminn (May 18th 2007, 5:05pm)

9 510

by SprinklerGuy

(May 25th 2007, 3:19am)

by gobris (May 14th 2013, 9:45am)

3 505

by Wet_Boots

(May 16th 2013, 8:30am)

by desmo907 (Aug 28th 2012, 3:54pm)

3 501

by desmo907

(Sep 4th 2012, 8:33am)

by OscarNav (Apr 17th 2005, 8:54pm)

2 501

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by DAVID LP (Jul 18th 2011, 10:55am)

2 497

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by ssherrid (Jul 21st 2010, 12:18am)

0 497

No reply

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 496

by Mitchgo

(Jul 19th 2011, 12:34am)

by dkraska (Aug 29th 2009, 2:41pm)

4 495

by hi.todd

(Aug 30th 2009, 9:32pm)

by macminn (Jun 11th 2007, 5:43pm)

2 494

by mrfixit

(Jun 7th 2008, 8:13am)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.35 Posts per Day)