You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Towelie427 (Yesterday, 7:10pm)

2 24

by irrigirl

(Today, 1:32pm)

by hadaX (Aug 28th 2014, 11:06am)

2 41

by irrigirl

(Aug 29th 2014, 5:33pm)

by rchead755 (Aug 23rd 2014, 11:36am)

2 23

by irrigirl

(Aug 25th 2014, 4:59pm)

by eddieruko (Jul 29th 2014, 4:52pm)

2 65

by eddieruko

(Jul 30th 2014, 12:31pm)

by Benmt (Jul 24th 2014, 11:01pm)

2 38

by Benmt

(Jul 25th 2014, 1:46pm)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,442

by mrfixit

(Aug 26th 2013, 8:00pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 289

by mrfixit

(Aug 14th 2013, 12:28pm)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 213

by mrfixit

(Jul 27th 2013, 2:59am)

by 7907 (May 3rd 2013, 12:55am)

2 228

by PennyInHeels

(Jun 25th 2013, 9:49am)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 361

by Ronblagrone

(Jun 12th 2013, 10:23pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)