You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Sartenose (Sep 22nd 2012, 2:31pm)

1 480

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by EtzGx (Jun 21st 2009, 12:40pm)

0 480

No reply

by boosted50 (Mar 18th 2004, 4:55am)

5 480

by boosted50

(Mar 20th 2004, 1:24pm)

by mack (Apr 18th 2012, 8:30pm)

2 479

by mack

(Apr 19th 2012, 12:54pm)

by nightshark (Sep 9th 2013, 3:11pm)

3 477

by mrfixit

(Sep 9th 2013, 6:05pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 476

by s123mith

(Jul 10th 2012, 5:21am)

by paul b (Jul 3rd 2010, 10:24am)

1 474

by Wet_Boots

(Jul 6th 2010, 9:21am)

by jwdawgs (Feb 26th 2007, 4:10pm)

11 468

by Tom

(Feb 28th 2007, 12:48pm)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 466

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by opsec (Apr 1st 2012, 7:44pm)

2 459

by Wet_Boots

(Apr 2nd 2012, 9:08am)

Show

Statistics:

436 Threads - 1,651 Posts (average 0.36 Posts per Day)