You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mack (Apr 18th 2012, 8:30pm)

2 473

by mack

(Apr 19th 2012, 12:54pm)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 114

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

4 2,224

by Jlinfield

(Jul 4th 2014, 11:42am)

by guy_sparky (Aug 12th 2010, 10:35am)

3 637

by mrfixit

(Aug 12th 2010, 5:12pm)

by Buff (Jun 6th 2008, 8:25am)

6 3,121

by mrfixit

(Jun 6th 2008, 1:59pm)

by waboehly (May 1st 2007, 6:51am)

1 332

by Tom

(May 1st 2007, 3:34pm)

by Shred Happy (Dec 21st 2011, 9:04am)

1 834

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by alf51175 (Aug 1st 2011, 9:53pm)

3 185

by alf51175

(Aug 2nd 2011, 8:02pm)

by Panic1978 (Jul 17th 2009, 6:52pm)

0 497

No reply

by labert (Jan 3rd 2004, 6:11am)

3 773

by labert

(Jan 7th 2004, 2:15pm)

Show

Statistics:

436 Threads - 1,647 Posts (average 0.36 Posts per Day)