You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by skimi (May 6th 2008, 12:27am)

5 2,189

by jbsbeach

(Jan 7th 2009, 7:18am)

by Brie (Feb 24th 2009, 11:42am)

2 548

by sanzen96

(Mar 21st 2009, 3:55pm)

by India (Mar 17th 2009, 7:07am)

5 359

by HooKooDooKu

(Mar 25th 2009, 10:16pm)

by PSpatches (Apr 28th 2009, 10:31am)

1 226

by Candance

(May 9th 2009, 9:13pm)

by kenball27 (May 1st 2009, 1:01pm)

3 2,372

by mrfixit

(May 10th 2009, 1:13pm)

by gbreiten (May 19th 2009, 10:18am)

0 99

No reply

by Jeff Nobles (May 21st 2009, 9:40am)

3 481

by hi.todd

(May 22nd 2009, 8:19pm)

by killerj (May 25th 2009, 10:32am)

0 182

No reply

by larbec7 (Jun 6th 2009, 5:07pm)

9 814

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 137

by hi.todd

(Jun 19th 2009, 10:23pm)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)