You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Marlene (Aug 23rd 2007, 3:11am)

4 587

by Marlene

(Aug 25th 2007, 5:42am)

by perplexed (Sep 8th 2007, 3:35am)

4 693

by perplexed

(Sep 9th 2007, 5:20am)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 381

by Wet_Boots

(Sep 15th 2007, 12:31am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 481

by Wet_Boots

(Sep 16th 2007, 7:55am)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 371

No reply

by tmshead (Oct 1st 2007, 4:35am)

2 491

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by ArrakeenIrrigator (Sep 14th 2007, 5:52am)

3 1,192

by edwildesr

(Oct 7th 2007, 6:49pm)

by sanddido (Oct 11th 2007, 3:39am)

1 412

by mrfixit

(Oct 11th 2007, 2:03pm)

by crazydayz (Oct 17th 2007, 6:33am)

0 340

No reply

by Dennis (Oct 15th 2007, 7:30am)

1 779

by edwildesr

(Nov 5th 2007, 7:53am)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)