You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 462

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 459

by Trabecca

(Mar 18th 2013, 8:23am)

by rsteffan (Aug 1st 2012, 6:14pm)

6 459

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by tbtech24 (Jun 9th 2011, 9:24am)

3 458

by Wet_Boots

(Jun 9th 2011, 10:09am)

by BenC (Apr 10th 2007, 6:32pm)

7 458

by BenC

(Apr 17th 2007, 5:38pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 456

by mrfixit

(Jul 20th 2012, 3:06pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 456

by hudr0004

(Oct 24th 2011, 8:38am)

by EtzGx (Jun 21st 2009, 12:40pm)

0 456

No reply

by Rick Hudspeth (May 31st 2006, 5:13am)

2 455

by Rick Hudspeth

(May 31st 2006, 7:35am)

by paul b (Jul 3rd 2010, 10:24am)

1 449

by Wet_Boots

(Jul 6th 2010, 9:21am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)