You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lloydlevy (Nov 28th 2011, 11:14am)

3 176

by Wet_Boots

(Nov 29th 2011, 8:22am)

by lou40 (Nov 9th 2011, 4:15pm)

3 543

by Wet_Boots

(Nov 13th 2011, 8:15am)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 568

by mrfixit

(Nov 10th 2011, 4:23am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 166

by alf51175

(Aug 2nd 2011, 8:02pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,106

by Mitchgo

(Jun 12th 2011, 2:13pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 465

by Wet_Boots

(Jun 9th 2011, 10:09am)

by kxaz145 (May 1st 2009, 2:52pm)

3 1,186

by Wet_Boots

(Jun 3rd 2011, 7:49am)

by Metalman1 (May 23rd 2011, 11:56am)

3 378

by sharon

(May 30th 2011, 12:20pm)

by krantzr (Apr 30th 2011, 8:26am)

3 1,057

by mrfixit

(May 1st 2011, 11:34am)

by stellar495 (Mar 17th 2011, 8:57pm)

3 1,452

by hi.todd

(Mar 20th 2011, 11:03am)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)