You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by betsycam (Oct 13th 2013, 4:26pm)

1 780

by Wet_Boots

(Oct 14th 2013, 10:18am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 774

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 768

No reply

by GraemeDunkley (May 4th 2013, 10:50pm)

5 766

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 765

by Mitchgo

(Jun 9th 2011, 10:08pm)

by xfevv (Oct 16th 2007, 4:52am)

4 765

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by Bob B (Oct 18th 2014, 9:31am)

17 764

by Wet_Boots

(Nov 1st 2014, 6:44am)

by Jimy (Aug 30th 2011, 11:45am)

4 764

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by Drski (Jul 29th 2011, 11:50am)

5 761

by Drski

(Aug 9th 2011, 11:04am)

by garen (Aug 8th 2012, 10:41pm)

7 758

by Wet_Boots

(Aug 24th 2012, 8:00am)

Show

Statistics:

465 Threads - 1,755 Posts (average 0.36 Posts per Day)