You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AZHomeOwner (May 7th 2011, 1:35pm)

1 540

by Mitchgo

(May 9th 2011, 1:04am)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 193

No reply

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 667

by Mitchgo

(Jul 19th 2011, 12:34am)

by orgits (Apr 9th 2011, 5:10pm)

2 1,289

by Mitchgo

(Apr 10th 2011, 2:29am)

by sirlar (Jul 20th 2012, 2:40pm)

0 348

No reply

by Jlivengood (Oct 20th 2012, 2:01am)

3 851

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 537

by xpedient

(Jul 2nd 2006, 3:34pm)

by MAG128 (Jun 24th 2015, 5:32pm)

3 289

by Wet_Boots

(Jun 26th 2015, 6:20am)

by glmcolo (Nov 27th 2006, 4:32am)

1 442

by Wet_Boots

(Nov 27th 2006, 6:04am)

by Bert Wall (Jan 23rd 2007, 7:40am)

5 645

by Wet_Boots

(Jan 25th 2007, 12:56pm)

Show

Statistics:

505 Threads - 1,934 Posts (average 0.37 Posts per Day)