You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Roger Stover (Jun 16th 2009, 11:09am)

4 216

by hi.todd

(Jun 19th 2009, 10:27pm)

by Wharfrat (May 16th 2008, 11:43am)

1 332

by mrfixit

(May 16th 2008, 5:43pm)

by pillboy (Jun 8th 2011, 6:40pm)

11 3,314

by Wet_Boots

(Jun 14th 2011, 2:26pm)

by tbatrof (Sep 10th 2011, 7:00pm)

2 307

by mrfixit

(Sep 10th 2011, 10:07pm)

by schlaiss (Jul 1st 2010, 9:25pm)

1 214

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Emblazed (Jul 24th 2010, 10:30am)

5 577

by Wet_Boots

(Jul 27th 2010, 10:48am)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 456

by mrfixit

(Dec 4th 2010, 1:48pm)

by RedArt (Aug 15th 2010, 11:03am)

3 1,679

by mrfixit

(Aug 31st 2010, 2:23pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 388

by hi.todd

(Jun 19th 2009, 10:24pm)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 468

by Wet_Boots

(Dec 26th 2012, 8:32am)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)