You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Shred Happy (Dec 21st 2011, 9:04am)

1 950

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by patk (Sep 18th 2011, 2:17pm)

2 766

by patk

(Sep 18th 2011, 3:41pm)

by Drski (Jul 29th 2011, 11:50am)

5 702

by Drski

(Aug 9th 2011, 11:04am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 220

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 812

by Wet_Boots

(Jul 13th 2011, 11:30am)

by krantzr (Apr 30th 2011, 8:26am)

3 1,320

by mrfixit

(May 1st 2011, 11:34am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 439

No reply

by ohiorebel (Apr 10th 2011, 8:59am)

2 404

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by Bumbleball (Sep 4th 2010, 12:15am)

10 586

by Bumbleball

(Sep 14th 2010, 9:06pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 564

by Wet_Boots

(Sep 9th 2010, 8:50pm)

Show

Statistics:

470 Threads - 1,750 Posts (average 0.36 Posts per Day)