You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Emblazed (Jul 24th 2010, 10:30am)

5 576

by Wet_Boots

(Jul 27th 2010, 10:48am)

by Frankpc (Jul 22nd 2010, 9:02pm)

0 990

No reply

by svsprinklers (May 19th 2010, 9:29pm)

2 1,127

by PhoenixDen

(Jun 24th 2010, 11:27am)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,554

by mrfixit

(Jun 2nd 2010, 2:27am)

by DRegs (May 5th 2010, 5:29pm)

1 354

by Wet_Boots

(May 6th 2010, 2:34pm)

by stillc (Jul 29th 2009, 12:36pm)

2 771

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 322

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Roger Stover (Jun 16th 2009, 11:09am)

4 214

by hi.todd

(Jun 19th 2009, 10:27pm)

by Brie (Feb 24th 2009, 11:42am)

2 656

by sanzen96

(Mar 21st 2009, 3:55pm)

by skimi (May 6th 2008, 12:27am)

5 2,469

by jbsbeach

(Jan 7th 2009, 7:18am)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)