You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mdige (Oct 31st 2011, 4:31pm)

1 734

by Wet_Boots

(Nov 1st 2011, 6:36am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 733

by Mitchgo

(Jul 1st 2011, 9:20pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 732

by hudr0004

(Oct 24th 2011, 8:38am)

by patk (Sep 18th 2011, 2:17pm)

2 726

by patk

(Sep 18th 2011, 3:41pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 723

by mrfixit

(Nov 10th 2011, 4:23am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 722

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by ddeferra (Jun 7th 2011, 10:46pm)

2 721

by ddeferra

(Jun 8th 2011, 6:29pm)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 721

by mrfixit

(Jul 22nd 2008, 9:30pm)

by orgits (Apr 9th 2011, 5:10pm)

2 718

by Mitchgo

(Apr 10th 2011, 2:29am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 712

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)