You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by guy_sparky (Aug 12th 2010, 10:35am)

3 648

by mrfixit

(Aug 12th 2010, 5:12pm)

by patk (Sep 18th 2011, 2:17pm)

2 646

by patk

(Sep 18th 2011, 3:41pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 646

No reply

by ddeferra (Jun 7th 2011, 10:46pm)

2 643

by ddeferra

(Jun 8th 2011, 6:29pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 641

by mrfixit

(Nov 10th 2011, 4:23am)

by PintoDr (Jun 28th 2012, 11:50pm)

5 640

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by mdige (Oct 31st 2011, 4:31pm)

1 635

by Wet_Boots

(Nov 1st 2011, 6:36am)

by xfevv (Oct 16th 2007, 4:52am)

4 634

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 621

by zenavttmn

(Apr 24th 2006, 1:21pm)

by orgits (Apr 9th 2011, 5:10pm)

2 620

by Mitchgo

(Apr 10th 2011, 2:29am)

Show

Statistics:

436 Threads - 1,653 Posts (average 0.36 Posts per Day)