You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by guy_sparky (Aug 12th 2010, 10:35am)

3 685

by mrfixit

(Aug 12th 2010, 5:12pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 684

by mrfixit

(Nov 10th 2011, 4:23am)

by KSknight (Aug 17th 2009, 10:53am)

1 684

by bdbengtsson

(May 21st 2010, 5:27pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 683

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by mdige (Oct 31st 2011, 4:31pm)

1 678

by Wet_Boots

(Nov 1st 2011, 6:36am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 674

by ddeferra

(Jun 8th 2011, 6:29pm)

by xfevv (Oct 16th 2007, 4:52am)

4 672

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 671

by Trabecca

(Mar 18th 2013, 8:23am)

by Texas Guy (May 23rd 2006, 5:48pm)

0 668

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 667

by Mitchgo

(Apr 10th 2011, 2:29am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)