You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AZHomeOwner (May 7th 2011, 1:35pm)

1 340

by Mitchgo

(May 9th 2011, 1:04am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 416

by Mitchgo

(Jul 19th 2011, 12:34am)

by orgits (Apr 9th 2011, 5:10pm)

2 609

by Mitchgo

(Apr 10th 2011, 2:29am)

by sirlar (Jul 20th 2012, 2:40pm)

0 186

No reply

by Jlivengood (Oct 20th 2012, 2:01am)

3 531

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 290

by xpedient

(Jul 2nd 2006, 3:34pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 228

by Wet_Boots

(Nov 27th 2006, 6:04am)

by Bert Wall (Jan 23rd 2007, 7:40am)

5 318

by Wet_Boots

(Jan 25th 2007, 12:56pm)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 574

by GatorGuy

(Jun 12th 2012, 8:36am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 315

No reply

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)